The Slowdown

Sign in to follow this  
  • entries
    141
  • comments
    32
  • views
    117,401

Destiny 2 Incompatible with AMD Phenom II?

Sign in to follow this  
vrap

1,119 views

Destiny-2-Logo.png

I just published my List of Games That No Longer Run on AMD Phenom a month ago, and then Bungie’s Destiny 2 launches on Oct 24th. The launch has raised the ire of tons of Phenom II users, as the game seems to be crashing mightily on those processors. In the developers’ known issues thread, the following SSSE requirement is mentioned:

  • SSSE3 Required: Destiny 2 will not run on processors without Supplemental Streaming SIMD Extensions 3 (SSSE3).

Wait, what? Usually, the common problem with games not running on Phenoms is their missing SSE 4.1+ support! This time around, the problem is SSSE3 (“Supplemental Streaming SIMD Extensions 3,” not to be confused with SSE3!), which is unfortunately supported in AMD processors only after the Bobcat architecture, released in early 2011.

Destiny 2 is only the second game released with the SSSE3 incompatibility, with Resident Evil 7 (which was later patched for support) being the first. The system requirements for the game are as follows:

Minimum Requirements Recommended Specifications
Operating System
Windows® 7 / Windows® 8 / Windows® 10 64-bit (latest Service Pack)
Windows® 7 / Windows® 8 / Windows® 10 64-bit (latest Service Pack)
Processor: Intel
Intel® Core™ i3 3250 3.5 GHz or Intel Pentium G4560 3.5 GHz
Intel® Core™ i5 2400 3.4 GHz or i5 7400 3.5 GHz
Processor: AMD
AMD FX-4350 4.2 GHz
AMD Ryzen R5 1600X 3.6 GHz
Video: NVidia
NVIDIA® GeForce® GTX 660 2GB or GTX 1050 2GB
NVIDIA® GeForce® GTX 970 4GB or GTX 1060 6GB
Video: AMD
AMD Radeon HD 7850 2GB
AMD R9 390 8GB
Memory
6 GB RAM
8 GB RAM

Destiny 2 is, honestly, the first game with minimum requirements that make me finally wonder whether it would actually run on my 3.8GHz Phenom II. All other incompatible games to date have had much lesser minimum requirements. Will investigate once the situation changes; other Phenom II users have reported that the game ran fine in beta, however.

Crucially, Bungie have added the following modifier to the SSSE3 incompatibility:

PLEASE NOTE: We’ve seen a number of reports of crashes on CPUs that fall below our stated minimum specs (E.G. AMD Phenom II series). We are investigating the issue and will attempt to fix the crash, but these CPUs are below minimum spec and are not officially supported.

What do we know to date?

  • Fixing the classic SSE4.1+ incompatibility has not been a major hurdle to developers at all.
  • I am so far unsure of the seriousness of the SSSE3 incompatibility, but it was fixed in Resident Evil 7, and
  • The Destiny 2 betas apparently did work for Phenom users.

Given that the betas did work – which comes off a little bit as false advertising -, the chance of the issue being fixed is relatively high. Whatever changed since launch? All in all, though, I must advise Phenom II users to not purchase the game and wait while the team attempts to amend the situation.

slowdown?i=bo0wHkdlYv8:RiwDsP7wgLk:D7DqB2pKExk slowdown?i=bo0wHkdlYv8:RiwDsP7wgLk:gIN9vFwOqvQ slowdown?i=bo0wHkdlYv8:RiwDsP7wgLk:V_sGLiPBpWU slowdown?d=qj6IDK7rITs slowdown?d=6et-BrRH4jw

Sign in to follow this  


0 Comments


Recommended Comments

There are no comments to display.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.